Not logged in. · Lost password · Register
Forum: General Help and Support Server Setup RSS
Impossible to migrate.. from dev1.mywiki.com to dev2.mywiki.com
Avatar
julian70400 #1
Member for a week · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: Impossible to migrate.. from dev1.mywiki.com to dev2.mywiki.com
Hello,

My wiki is.. down.

I was migrating Dokuwiki from server A to server B, through I had also to modify URL.

I backuped my files, put them on the new server, set the new url. Everything seemed to be Ok. I did nothing else.

But when I tryed to modify my nginx configuration to use Content Security Policy, with img-src, I saw no image on the new wiki.. Did not understand why until I checked the console log : all urls of the images are still pointing to dev1.mywiki.com instead of the new url which is dev2.mywiki.com.

I had a look to your server move FAQ, and I saw I "just" have to save a new time the configuration.
I did it and.. it brake everything (mainly the template).. and also, I still have references to my old url in my files.

==>I tryed to force baseurl and basedir with the new url, but still same problem..

Mainly, all corrupted files with old url are in /data/pages and /data/cache and ../meta
==> I tryed to sed dev1 by dev2 in each files, same problem..

==> tryed to desactivate all plugins, same

==> tryed to reinstall bootstrap3 them, same (anyway, even the original theme seem to be broken)

==> cleared my browser cache x times.. same

Here is an exemple of the problem, the template is totally fu***up (I am in the configuration menu, with bootstrap3 and yeti theme) :

[Image: https://pasteboard.co/IIEiK5z.png]

So, what now ? What can I do to migrate restore my new Dokuwiki (because I wrote a lot of things between migration and now..) ?

Is there a where to migrate Dokuwiki safely through modifying also URL or it's not possible ?

Thanks..
This post was edited 4 times, last on 2019-11-27, 18:25 by julian70400.
Avatar
julian70400 #2
Member for a week · 2 posts
Group memberships: Members
Show profile · Link to this post
Ok guys, as I am found solution, I share..

The main problem was for security reasons, I disabled parse_ini_file function in my php.ini.

Even if I enable it again, problemis still the same.. normal : I had to remove everything in /data/cache/

After purging also my cache on browser side, I tryed it again and everything worked like a f* charm.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-06, 09:44:33 (UTC +01:00)