Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
install.php problem
Avatar
Rockrabbit #1
Member since Oct 2006 · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: install.php problem
Hello

I've uploaded DokuWiki to a shared server with no problems and brought up the install.php page on my browser, which is headed DokuWiki Intstaller. This provides a form for me to complete to set up the Wiki name, enable ACL etc. However what ever I enter into this form it simply comes back with the error "Superuser - illegal or empty name".

Can anyone tell me what I'm doing wrong?

Thanks in advance, RockRabbit
Avatar
koko #2
Member since May 2006 · 161 posts · Location: Zonhoven Belgium
Group memberships: Members
Show profile · Link to this post
Hi,

Have you checked the file permissions?
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
Avatar
andi (Administrator) #3
User title: splitbrain
Member since May 2006 · 3520 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post #1
Quote by Rockrabbit:
what ever I enter into this form it simply comes back with the error "Superuser - illegal or empty name".

What did you put in the username field exactly? It should be a single word (preferable in ASCII - not sure about this) no special chars, no spaces.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
Rockrabbit #4
Member since Oct 2006 · 2 posts
Group memberships: Members
Show profile · Link to this post
Andi

I think I used the name 'Admin' or 'Administrator' or similar. Certainly a single word with no strange characters.

Koko

I'll re-check the permissions - just seemed an odd message for a file permission error.

Thanks, RockRabbit
Avatar
andi (Administrator) #5
User title: splitbrain
Member since May 2006 · 3520 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
I just checked the code. The superuser should be completely lowercase. So 'Admin' should be 'admin' instead. I will change the code to automatically lowercase the input.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-02-17, 08:01:50 (UTC +01:00)