Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Lost admin password
Avatar
ossy81 #1
Member since Oct 2008 · 1 post
Group memberships: Members
Show profile · Link to this post
Subject: Lost admin password
Hi,

is it possible to "reset" the admin password. I didn't use the account for a while and lost my notes with the password.
It's not a problem to reinstall it, but i don't want to loose the content.

Please advice what to do.

regards,

Osman
Avatar
andi (Administrator) #2
Member since May 2006 · 2449 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Use the "forget my password" link. If that's disabled, edit the conf/users.auth.php file and replace the crypted password with a new crypt. Eg. use 21232f297a57a5a743894a0e4a801fc3 to set the password to admin. Be sure to change it later.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
dude #3
Member since Jun 2011 · 1 post
Group memberships: Members
Show profile · Link to this post
In reply to post #1
Subject: UPDATE! PASSWORD RESET
# it seems to make no difference where to set the password !?
sudo vim /var/lib/dokuwiki/acl/users.auth.php
sudo vim /etc/dokuwiki/users.auth.php

# the correct line for newer version of dokuwiki 06.2011 for admin:admin is:
admin:$1$4fd0ad31$.cId7p1uxI4a.RcrH81On0:DokuWiki Administrator:mail@host.com:admin,user
Avatar
lupo49 (Moderator) #4
Member since Jul 2009 · 1397 posts · Location: Warstein, Germany
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
/etc/dokuwiki/user.auth.php is symlink which redirects to the /var/lib/.. file.
Avatar
dominik #5
Member since Apr 2009 · 384 posts · Location: Berlin, Germany
Group memberships: Members, Wiki Managers
Show profile · Link to this post
another way how to handle forgotten passwords is here
http://www.dokuwiki.org/faq:forgotten_password
Avatar
greybeard #6
Member since Jun 2010 · 5 posts
Group memberships: Members
Show profile · Link to this post
Still working on getting my install to send e-mail successfully, so I cannot use "lost password" feature.

Editing the conf/users.auth.php has worked in the past, but does not work today with latest code release installed. 

Paths such as those mentioned earlier in this thread do not exist in my install:
/var/lib/dokuwiki/acl/users.auth.php
/etc/dokuwiki/users.auth.php

Is there a new procedure?


Latest status:
No idea why this didn't work yesterday, but now suddenly I'm in.  mind-boggling.  thanks for support guys.
This post was edited on 2011-09-04, 20:02 by greybeard.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20120620-dev, © 2003-2011 by Yves Goergen
Current time: 2014-04-24, 18:08:38 (UTC +02:00)