Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Lost admin password cannot login anymore
Avatar
vfbsilva #1
Member since Jul 2009 · 2 posts
Group memberships: Members
Show profile · Link to this post
Subject: Lost admin password cannot login anymore
Folks I lost my admin password and I can no longer log in. So I changed my password in users.auth.php to 21232f297a57a5a743894a0e4a801fc3
So the file was as follows:
user_name:21232f297a57a5a743894a0e4a801fc3:XXXXXXX:XXX@XXXXXX:admin,user
still I could not login under user_name with admin as password what can I do?
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 4675 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Well, this might seem a bit round about.  But since you seem to have access to the server, you could create an entirely new  installation of DW, create a new user admin account and then copy your new authorization line from the new install to the old, and then make a backup of your users.auth.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
chi #3
Member since Jun 2006 · 1851 posts · Location: Munich Germany
Group memberships: Members, Super Mods, Wiki Managers
Show profile · Link to this post
In reply to post #1
Did you use the same hashing algorithm as configured on your install (i.e. md5, smd5 (default))?
Please add [SOLVED] to the initial thread subject if you feel your question has been answered.
If my answer doesn't make sense maybe your question didn't either - just visit http://facepalm.org.
Avatar
andi (Administrator) #4
User title: splitbrain
Member since May 2006 · 3450 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Quote by chi:
Did you use the same hashing algorithm as configured on your install (i.e. md5, smd5 (default))?

Doesn't matter. DokuWiki recognizes the used hashing method itself.

vfbsilva, what are the symptoms? do you get any error messages? Did you maybe configure a different auth backend than the default plain one?
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
turnermm (Moderator) #5
Member since Oct 2009 · 4675 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Quote by andi:
Quote by chi:
Did you use the same hashing algorithm as configured on your install (i.e. md5, smd5 (default))?

Doesn't matter. DokuWiki recognizes the used hashing method itself.


I found that when moving a dokuwiki from linux to Mac OS X, I couldn't get password recognition and had to reset the passwords.  The OS X hashes were significantly shorter in number of characters.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
ach (Administrator) #6
Member since May 2006 · 1921 posts · Location: Folkestone, UK
Group memberships: Administrators, Members, Super Mods, Wiki Managers
Show profile · Link to this post
In reply to post #1
See http://www.dokuwiki.org/faq:forgotten_password.
Avatar
andi (Administrator) #7
User title: splitbrain
Member since May 2006 · 3450 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post #5
Quote by turnermm:
I found that when moving a dokuwiki from linux to Mac OS X, I couldn't get password recognition and had to reset the passwords.  The OS X hashes were significantly shorter in number of characters.

I doubt that. If you can reproduce this, please submit a bug report.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
turnermm (Moderator) #8
Member since Oct 2009 · 4675 posts · Location: Canada
Group memberships: Global Moderators, Members, Super Mods
Show profile · Link to this post
Just re-tested and the same problem shows up.  OS X does not recognize Linux Passwords.  I submitted a bug report.
Myron Turner
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
breeni #9
Member since Jun 2010 · 1 post
Group memberships: Members
Show profile · Link to this post
I have copied a docuwiki instance from OS X to Linux and I experience the same issue with password hashes not being recognised. I can't find the bug you submitted, what was the number?
Thanks.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-07-23, 14:19:28 (UTC +02:00)