Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
yet another writing... failed
Avatar
ingo #1
Member since Dec 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Subject: yet another writing... failed
Hi there,

just installed dokuwiki and am getting these strange messages:

Writing /www/110mb.com/t/o/a/d/_/_/_/_/toad/htdocs/data/cache/9/92e131e8271606e77423f04b601fc8d9.i failed
Writing /www/110mb.com/t/o/a/d/_/_/_/_/toad/htdocs/data/cache/9/92e131e8271606e77423f04b601fc8d9.xhtml failed

So I searched the forum and chmod seemed to be the answer. Unfortunately 110mb.com doesn't have this function (nor .htaccess nor shell access) and I've allocated as many rights as is possible using their interface - unfortunately no change. BTW, my cache folder is under /data/cache, so I am not really sure where dokuwiki got its wild paths from (but then again I wouldn't, anyway :) )

Can anybody out there point me in the right direction?

Thanks in advance!
Avatar
koko #2
Member since May 2006 · 161 posts · Location: Zonhoven Belgium
Group memberships: Members
Show profile · Link to this post
hi,

Maybe fixperms.php might help?
I think it is the solution for your problem ;-)
Programming today is a race between software engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
Avatar
ingo #3
Member since Dec 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Many thanks for the tip, koko. Tried it out straight away but got an unbelievable amount of error messages and no change in the original error messages. Unfortunately I still have no ftp nor shell access, so I cannot do anything manually...
Avatar
andi (Administrator) #4
User title: splitbrain
Member since May 2006 · 3500 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
In reply to post #2
Quote by koko:
Maybe fixperms.php might help?
I think it is the solution for your problem ;-)

Everybody: DON'T USE THIS SCRIPT UNLESS YOU UNDERSTAND WHAT IT DOES! (sorry for screaming)

ingo, read http://wiki.splitbrain.org/wiki:install:permissions and understand and follow the advices there. If it still doesn't work, you might have a problem with PHP's safemode, read more on http://wiki.splitbrain.org/wiki:safemodehack.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
ingo #5
Member since Dec 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Thanks andi - am in the process of running the script now. Wonder whether it will undo any of the damage fixperms.php inflicted...

I'll report back in due time.

Ingo
Avatar
ingo #6
Member since Dec 2006 · 4 posts
Group memberships: Members
Show profile · Link to this post
Right, ran the script below

 
<?php
 
if(function_exists('posix_geteuid')){
    // use posix to get current uid and gid
    $uid   = posix_geteuid();
    $usr   = posix_getpwuid($uid);
    $user  = $usr['name'];
    $gid   = posix_getegid();
    $grp   = posix_getgrgid($gid);
    $group = $grp['name'];
}else{
    // try to create a file and read it's ids
    $tmp = tempnam ('/tmp', 'check');
    $uid = fileowner($tmp);
    $gid = filegroup($tmp);
 
    // try to run ls on it
    $out = `ls -l $tmp`;
    $lst = explode(' ',$out);
    $user  = $lst[2];
    $group = $lst[3];
    unlink($tmp);
}
 
echo "Your PHP process seems to run with the UID $uid ($user) and the GID $gid ($group)\n"; ?>

and got this output
Your PHP process seems to run with the UID 2001 (vhostswww) and the GID 2001 (vhosts)

I am then told
Which permissions to set?

So, how should you set the permissions of the directories mentioned above?

Hm, did they really mention any directories above? Did I miss something or am I just plain stupid (a possibility never to be discounted...). I certainly don't know php and this might be my downfall - do I have to learn it to run dokuwiki?

My problem is that dokuwiki creates directories which do not exist - that is they do not exist when I look at my directory tree before AND after. How then should I assign permissions to something that is abstract?

Will now attempt the safehack site and see whether anything comes out of that. Thanks for all your help so far!

Cheers
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-20, 01:14:45 (UTC +01:00)