Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.
Avatar
bobsworld #1
Member since Sep 2011 · 1 post
Group memberships: Members
Show profile · Link to this post
Subject: Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.
Hi

I just installed DokuWiki. I followed the instructions at http://www.dokuwiki.org/Install:
  • downloaded the archive and extracted it
  • uploaded it
  • ran install.php
  • changed permissions for config and data (777 recursive)

But I still get the following error:
Writing /home/***/data/cache/4/4ff0e0fb4c5fafe571526876073eb26b.i failed
Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.
Writing /home/***/data/cache/4/4ff0e0fb4c5fafe571526876073eb26b.metadata failed

I'm able to create new pages (I see new txt-files in the pages dir) but it seems the cache can't be created.

I can't turn off safe_mode and tried the safemode hack, but that didn't help either :-(

Anybody any suggestions or ideas. Things I can try?
This post was edited on 2011-09-06, 20:37 by bobsworld.
Avatar
tonybaldwin #2
User title: non compos mentis
Member since Feb 2011 · 4 posts · Location: connecticut, usa
Group memberships: Members
Show profile · Link to this post
Subject: possibly resolved
Seeing something similar on a wiki that has been up and running fine for a couple of years, no new installation.
no clue what the problem is, although apache logs indicate some confusion with some SNI issue, which is odd,
there's only 1 ssl site on my server and the wiki isn't it.

Seeing: Writing /home/tonyb/www/wiki/data/meta/start.meta failed
Unable to save metadata file. Hint: disk full; file permissions; safe_mode setting.
Writing /home/tonyb/www/wiki/data/cache/4/4a63570a867c9d0a2f7d504fc5c14c3a.xhtml failed


I turned off the ssl ( a2dismod ssl) and disabled that one ssl site, and it made no difference, still see this on the wiki index page (doku.php/start).
I see more at doku.php/start?do=admin.
I checked the disk space with df - h and df -i, neither disk space nor inodes are anyway near in danger of being filled.

I went to
www/wiki/data/cache, everything was 754 and I did chmod -R 770 *  and the msgs went away.
Itś all owned by me:www-data, so only I and the server can write to that directory now,
it was complaining because it wasn't able to write there, is seems, and thought, thus, that the disk was full or something.
I hadn't done anything recently to change any permissions in there,  so I'm a little lost as to why this happened.
This post was edited 2 times, last on 2016-09-30, 23:40 by tonybaldwin.
Avatar
SFITCS #3
User title: Scott Ferguson
Member since Dec 2014 · 464 posts · Location: Canberra, Australia
Group memberships: Members
Show profile · Link to this post
I'm assuming you checked quota?
Avatar
jukwaphil #4
Member since Nov 2018 · 1 post
Group memberships: Members
Show profile · Link to this post
Subject: Same error
This happened to me today. I went to the cache directory and deleted all the files. Suddenly all has come good again. Hope it might help someone reading this.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-12-08, 03:58:19 (UTC +01:00)