Not logged in. · Lost password · Register
Forum: General Help and Support Installation and Configuration RSS
Image upload failed after 2012-01-25a “Angua” update
Page:  1  2  next 
Avatar
chtiland #1
Member since Jul 2008 · 13 posts · Location: Lille France
Group memberships: Members
Show profile · Link to this post
Subject: Image upload failed after 2012-01-25a “Angua” update
First I installed a new dokuwiki, and I was not able to upload image, even the dokuwiki logo can't be use and is not displayed.

Then I try on an old version of dokuwiki on the same server, images can be upload and display.
I update this dokuwiki to the Angua version, and then onlys images that were already upload before update work.
I can't update any image on this dokuwiki too.

What's wrong ?

I tried to download and upload the update twice but still not working.
I tried to upload from mediamanager, and also directly from FTP but not working.

I also tried with default template, remove cache files after each try...

PHP Version : 5.2.17
GD : anabled / version : bundled (2.0.34 compatible)

Here is a screenshot of what I got on the new installation (note that sizes and format are well recognized) :

[Image: http://www.chtiland.com/contribs/dokuwiki_imageuploadpb.png]
Avatar
turnermm (Moderator) #2
Member since Oct 2009 · 2321 posts
Group memberships: Global Moderators, Members
Show profile · Link to this post
Have you checked the permissions?
Myron Turner
fckgLite (&ckgedit): http://www.mturner.org/fckgLite/
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
chtiland #3
Member since Jul 2008 · 13 posts · Location: Lille France
Group memberships: Members
Show profile · Link to this post
That's the first thing I checked.
Avatar
Taggic (Moderator) #4
Member since Jan 2011 · 738 posts · Location: Gilching, Germany
Group memberships: Global Moderators, Members
Show profile · Link to this post
I can't update any image on this dokuwiki too.

Have you checked the existence of \data\media_attic and \data\media_meta folders ? Don't know about impacts if it is not existent but after update from older to Angua version it might be missing and cause mysterious behavior.
best regards
Taggic
f-con wiki: http://www.fristercons.de/fcon/
Avatar
肉まん #5
User title: し初心者
Member since Dec 2011 · 4 posts · Location: ジャポーネ
Group memberships: Members
Show profile · Link to this post
In reply to post #1
This was the exact problem I had!

The reason was due to the difference in the default theme in "2012-01-25a Angua" and the theme that I created based on the older version. After switching to the default theme I could upload without problem. (-;
Avatar
MattH7 #6
Member since Apr 2012 · 2 posts
Group memberships: Members
Show profile · Link to this post
Same problem as posted above with new version of Dokuwiki. Go into edit page, click on add document. Can browse already uploaded documents, but the upload button does nothing when clicked. No javascript error except on initial load of mediamanager, and changing the theme back to default doesn't fix the problem.

Initial js error on load of mediamanager is:

Timestamp: 27/04/2012 6:15:46 PM
Error: func is undefined
Source File: http://intranet.lib.flinders.edu.au/dokuwiki/lib…?tseed=…
Line: 1

Have checked permissions, and all folders are created and have permission for web account to write to. Tried in firefox 11 and IE 9.
Avatar
turnermm (Moderator) #7
Member since Oct 2009 · 2321 posts
Group memberships: Global Moderators, Members
Show profile · Link to this post
You will get more information if you go the the configuration manager and uncheck the compress option for javascript and css.
Myron Turner
fckgLite (&ckgedit): http://www.mturner.org/fckgLite/
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
MattH7 #8
Member since Apr 2012 · 2 posts
Group memberships: Members
Show profile · Link to this post
Gone into the wiki configuration page and unticked js and css compression option. Saved and then cleared browser cache and removed dokuwiki cache files to be sure.

Went in to edit page and still get the error about truncated js. Still can't upload and the problem occurs under IE9 and FF11.

Should clarify that problem occurs on different line now:

Timestamp: 30/04/2012 11:12:46 AM
Error: func is undefined
Source File: http://intranet.lib.flinders.edu.au/dokuwiki/lib…?tseed=…
Line: 25760

ie:

function DEPRECATED_WRAP(func, context) {
    return function () {
        DEPRECATED();
        return func.apply(context || this, arguments);
    };
}
This post was edited on 2012-04-30, 03:48 by MattH7.
Avatar
turnermm (Moderator) #9
Member since Oct 2009 · 2321 posts
Group memberships: Global Moderators, Members
Show profile · Link to this post
It's very puzzling that you would be getting an error from this function. 

This function occurs in lib/scripts/compatability.js at line 37.  You could try this:

function DEPRECATED_WRAP(func, context) {
   try {
        return function () {
            DEPRECATED();
            return func.apply(context || this, arguments);
        };
  }catch(ex) {
      alert(ex);
    }
}

This might give you some idea of where the error is coming from and it will trap the error and so you might then be able to upload, depending on the nature of the underlying problem.  Try it in all of your browsers.  Firefox will probably give you the most detail.  Start by clearing out the Dokuwiki cache, because DW caches the javascript.  And clear out the browser cache as well.  You might have to do these things a few times.
Myron Turner
fckgLite (&ckgedit): http://www.mturner.org/fckgLite/
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
chtiland #10
Member since Jul 2008 · 13 posts · Location: Lille France
Group memberships: Members
Show profile · Link to this post
More and more strange

Working on my new dokuwiki with Firefox without problem, When I upload images, I always have "Failed", but I can use images.

When I open this page : http://auteria.fr/doku.php?id=encyclopedie:npcs:lisa

under Firefox 12 (but only the one I use to upload images), I got image at right, and icone in bottom list.

But under Chromium, Opera, or Firefox on another computer, no image.

Really annoying... My opinion of Dokuwiki decrease day after day.  :#:
Avatar
turnermm (Moderator) #11
Member since Oct 2009 · 2321 posts
Group memberships: Global Moderators, Members
Show profile · Link to this post
I ran your page on firefox and chrome in windows, and on firefox and chrome in ubuntu.  As far as I can see, there is no difference in the output.  All of them show an image at the right of a girl in an oval.  The problem appears to be local to your own setup.
Myron Turner
fckgLite (&ckgedit): http://www.mturner.org/fckgLite/
github: https://github.com/turnermm
plugins, templates: http://www.mturner.org/devel
Avatar
nickm #12
Member since Jun 2012 · 5 posts
Group memberships: Members
Show profile · Link to this post
I just noticed this issue also. I can upload fine in IE9 but when trying to upload in Firefox, it just fails immediately
stanikin #13
Member since Aug 2012 · 3 posts
Group memberships: Members
Show profile · Link to this post
Subject: Image Failure
Hi,

We're testing DocuWiki for possible use as internal and external documentation tool. We've been running a test version on windows for a couple of weeks and testing some of the features. I came up against this problem and am concerned by the lack of any constructive solutions. Was anyone successful in solving this problem other than use an IE browser to upload images? Do you expect there to be a patch or fix of some sort for this issue? Thanks in advance for your help. I don't want to make the wrong choice and select a product that is quite good but so poorly supported.
Avatar
ach (Administrator) #14
Member since May 2006 · 1334 posts · Location: London, UK
Group memberships: Administrators, Members, Super Mods, Wiki Managers
Show profile · Link to this post
Has anyone of you actually posted a bug report about this?
stanikin #15
Member since Aug 2012 · 3 posts
Group memberships: Members
Show profile · Link to this post
Subject: you mean like this one...
https://bugs.dokuwiki.org/index.php?do=details&task_id…

there seems to be plenty of chatter about all around in all sorts of languages.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Page:  1  2  next 
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20120620-dev, © 2003-2011 by Yves Goergen
Current time: 2014-04-18, 12:45:54 (UTC +02:00)