Not logged in. · Lost password · Register
Forum: General Help and Support Server Setup RSS
Get rid of those ajax.php messages?
Not critical (i think) but annoying.
Avatar
SaThaRiel #1
Member since Apr 2007 · 6 posts
Group memberships: Members
Show profile · Link to this post
Subject: Get rid of those ajax.php messages?
Hi,

i have created a dokuwiki on our providers webspace. The installation went straight forward and without any problems.
The provider uses cpanel for customer installations and management. As far as i could find out they use PHP 4, Apache 1.3 and Linux 2.6 as kernel.
The problem: When i start editing a page after some seconds (around 30 i think) a message appears

DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
Forbidden
You don't have permission to access /wiki/lib/exe/ajax.php on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/1.3.37 Server at www.mysite.com Port 80

Sure, the 404 error message comes from the fact its not defined. But the ajax-message is what i care about. As far as i can see everything works fine but the message is annoying.
I already searched here in the forum, in the wiki and google but i couldnt find anything useful for me (im quite new to provider managed webspace and also to webserver site handling).
The file permissions on the ajax.php-file seem to be ok. I cant set files/directories to 777 (for tests) since the security setting of the provider forbid this.

Please help me out with this - i really have no idea what to do else.
This post was edited on 2007-04-27, 17:18 by SaThaRiel.
Avatar
maxmatthew #2
Member since May 2007 · 1 post
Group memberships: Members
Show profile · Link to this post
Quote by SaThaRiel on 2007-04-27, 14:30:
Sure, the 404 error message comes from the fact its not defined. But the ajax-message is what i care about. As far as i can see everything works fine but the message is annoying.
I already searched here in the forum, in the wiki and google but i couldnt find anything useful for me (im quite new to provider managed webspace and also to webserver site handling).

I too am plagued by this ajax message and have searched the forums and tried a few tweaks in the files to no avail. Any ideas?

Matthew
Avatar
andi (Administrator) #3
User title: splitbrain
Member since May 2006 · 3520 posts · Location: Berlin Germany
Group memberships: Administrators, Members
Show profile · Link to this post
Call http://yourserver/wiki/lib/exe/ajax.php directly, then see why you get a permission denied. Maybe the directory is not accessable by your webserver? Too strict .htaccess rules? This is a problem with your webserver setup which you need to solve.
Read this if you don't get any useful answers.
Lies dies wenn du keine hilfreichen Antworten bekommst.
Avatar
SaThaRiel #4
Member since Apr 2007 · 6 posts
Group memberships: Members
Show profile · Link to this post
Yeah, i thought so too - and im not able to execute the file directly.
But im not sure which .htaccess must be modified - and how. Well, i think i can figure out how but sure i need to know which one.
I will try the one in my wiki-directory.

Here the error message:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@yourserver.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Well, no need to say that im the webmaster in first place...since the server is shared they wouldnt change settings only for our needs.

EDIT: OK, now i can access ajax.php on the server directly - i played around before to get it working and set the file permissions to 777 (just in case). My provider configured his webserver to disallow any access to such files. After i changed it back to 755 its accessible directly (well, just a blank page), but the error in the dokuwiki stays.
I have no idea anymore - i already browsed through the .htaccess parameters and found nothing useful for me.
This post was edited on 2007-05-16, 20:19 by SaThaRiel.
Avatar
SaThaRiel #5
Member since Apr 2007 · 6 posts
Group memberships: Members
Show profile · Link to this post
Well, the provider did a switch to a new server which messed around with the webserver user. So i need to fix the permissions on data and config directories. Now the problem seems to be solved but i have 757 directories and 646 files :( Dont like this...
But i dont have found the answer for the problem until now - maybe an idea? I just had to set them this way because the directories werent not writeable anymore by the webserver user - before it was fine, webserveruser=webdirectory owner...
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2020-02-17, 07:16:45 (UTC +01:00)