Not logged in. · Lost password · Register
Forum: Non-English Discussion Russian discussion RSS
[solved] не работает вход и регистрация
(после заливки на хостинг)
Avatar
Juray #1
Member since Sep 2012 · 20 posts · Location: Russia
Group memberships: Members
Show profile · Link to this post
Subject: [solved] не работает вход и регистрация
Настроил вики на локальном сервере, залил на хостинг - и там не смог ни войти, ни зарегистрироваться заново.
Никаких сообщений - страница с формой просто перезагружается.
Сверил файлы - расхождений нет. На всякий случай перезалил всю папку conf - безрезультатно.
Залил на другой (резервный) хостинг - там всё нормально.

Видимо, в настройках сервера причина. Вопрос - в каких? Что спрашивать у саппорта?

Посмотрел phpinfo - На этом "проблемном" хостинге стоит PHP Version 5.3.8-ZS5.5.0, у меня на локальном 5.3.3, на резервном хостинге - 5.2.11.
Еще заметил что на проблемном Virtual Directory Support - disabled, а на обоих рабочих - enabled. Только не думаю, что дело в этом.

Версия dokuwiki - 2012-10-13 Adora Belle.
Причем, ранее стоявшая на том хостинге Angua таких проблем не выдавала.
This post was edited on 2012-12-28, 16:21 by Juray.
Avatar
Juray #2
Member since Sep 2012 · 20 posts · Location: Russia
Group memberships: Members
Show profile · Link to this post
Уточнение проблемы:
форма перестает работать после установки userewrite "средствами сервера" (и соответствующей корректировки htaccess - то есть использование htaccess.dist с раскомментированием правил преобразования).

Вставка отладочного вывода и использование FireBug показало, что doku.php не получает параметры POST, только GET.

Видимо, дело все же в сервере.
Avatar
Juray #3
Member since Sep 2012 · 20 posts · Location: Russia
Group memberships: Members
Show profile · Link to this post
Еще дополнение: то же самое при userewrite=2 (средствами dokuwiki).
Avatar
Juray #4
Member since Sep 2012 · 20 posts · Location: Russia
Group memberships: Members
Show profile · Link to this post
Все, проблема решена - дело было не в докувики, а в сервере.
Из-за ошибки в конфиге nginx не отдавал апачу POST-запросы, если не видел запрашиваемого файла - при этом GET проходил.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-11-12, 05:48:08 (UTC +01:00)