Not logged in. · Lost password · Register
Forum: General Help and Support General Stuff RSS
Icons and logo does not display
Icons and logo does not display
Avatar
yishan_ma #1
Member since Jan 2019 · 4 posts
Group memberships: Members
Show profile · Link to this post
Subject: Icons and logo does not display
I opened the website a few days ago and all the logo and icons are not displayed.
These image files exist on the server. The HTTP status code of the request log is 200, but the response information of the image in the developer tool of the browser is 'This request has no response data available', and the version of dokuwiki is 2015-08-10.
Avatar
Michaelsy #2
Member since Jun 2015 · 887 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Did it happen out of the blue? Was nothing changed in DokuWiki or on the server?
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
yishan_ma #3
Member since Jan 2019 · 4 posts
Group memberships: Members
Show profile · Link to this post
Nothing was changed in DokuWiki and on the server.
Avatar
Michaelsy #4
Member since Jun 2015 · 887 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Maybe your provider has something changed? File permissions or PHP Version? (Or is something else in question?)

I once had the case that my provider had changed the PHP version on its own.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
Michaelsy #5
Member since Jun 2015 · 887 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
I think the version of the webserver is still in question. In this case probably an upgrade to the newest DokuWiki version (Greebo) is the best way.

Can you directly access the images via the corresponding URL? Something like this:
https://www.dokuwiki.org/lib/tpl/dokuwiki/images/logo.png
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
yishan_ma #6
Member since Jan 2019 · 4 posts
Group memberships: Members
Show profile · Link to this post
I tried to update the dokuwiki to the latest version, but the icon still doesn't show up, and I can't directly access the images via the corresponding URL, for example, http://dokuwiki.addnewer.com/dokuwiki/lib/tpl/vector/stati….
Avatar
Michaelsy #7
Member since Jun 2015 · 887 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Quote by yishan_ma:
I can't directly access the images via the corresponding URL, for example, http://dokuwiki.addnewer.com/dokuwiki/lib/tpl/vector/stati….

This read access is a minimum requirement. If the file exists and the ULR is correct, then probably something is wrong with the access rights. How they are set depends on your web server. In the typical installation on Linux with the Apache web server, the access rights depend on the directory and file permissions. And of the .htaccess files, which can also be found in the subdirectories of DokuWiki. They determine what the web server is allowed to deliver and what not.

I found something very interesting. Someone with obviously the same problem as you, has found the following solution:

Just tried with Apache 2.2 instead of 2.4 and it works
Source: https://forum.dokuwiki.org/post/62975

This fits in with my idea that your provider has changed the web server version.


After I had written all these stuff, then I have probably found the solution here:
https://github.com/arsava/dokuwiki-template-vector/issues/63

As far as I understand, you have to change the .htaccess file in the root directory of the vector template:
https://github.com/arsava/dokuwiki-template-vector/blob/ma…

Feedback welcome, especially for the support of other users!

    - Michael Sy.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Avatar
yishan_ma #8
Member since Jan 2019 · 4 posts
Group memberships: Members
Show profile · Link to this post
Hi Michaelsy:
    I use nginx as my web server, and  I have never changed the version of the web server.
    The permission of vector directory is 755, and the permission of image files are 644. I tried to directly access the images via the corresponding URL, for example http://192.168.0.10:8080/dokuwiki/lib/tpl/vector/static/img/button-rss.png, the page is blank and the status code  is 200 in headers but the response is 'This request has no response data available'.
Avatar
Michaelsy #9
Member since Jun 2015 · 887 posts · Location: Düsseldorf, Germany
Group memberships: Members
Show profile · Link to this post
Hi yishan_ma,

Too bad, I thought we had it. But now my possibilities are exhausted.

If you (or someone else here in the forum) have found the solution, please announce it here. So that others can benefit from it.

I wish you good luck - Michael Sy.
By Patreon.com a few eurons can be fed into the code phasers of
the DokuWiki engine. Besides, Andi's posts are worth reading.
Close Smaller – Larger + Reply to this post:
Verification code: VeriCode Please enter the word from the image into the text field below. (Type the letters only, lower case is okay.)
Smileys: :-) ;-) :-D :-p :blush: :cool: :rolleyes: :huh: :-/ <_< :-( :'( :#: :scared: 8-( :nuts: :-O
Special characters:
Go to forum
Imprint
This board is powered by the Unclassified NewsBoard software, 20150713-dev, © 2003-2015 by Yves Goergen
Current time: 2019-05-25, 19:45:14 (UTC +02:00)